★立即注册★

QQ登录

就爱江湖-众多辅助工具破解软件资源分享论坛-Www.92Jh.Cn

查看: 4262|回复: 161

[原创教程] LOL找喊话CALL基址教程9.20

  [复制链接]

签到天数: 154

今日第1个签到

发表于 2019-6-22 20:56:15 | 显示全部楼层
补充:
如果第一次搜索不到视频的%d ms的静态地址,不停的搜索多几次就可以了,就会出现。
或者进泉水的一刻马上搜索,基本就会搜索到了,还是没有就重新进下游戏,多搜索几次。
搜索到的静态地址的数值不一定显示是%d ms,这个数值可能会变化,
只要你是通过一开始搜索%d ms,搜索出有一个绿色的静态的地址就对了,不用管它数组是不是%d ms,然后对那个静态地址查找访问即可。

2019.7.11补充视频
关于有部分童鞋说失效,请仔细看多下视频和我写的补充,这里我再上传一个演示找那个文本静态地址视频。
游客,当前主题有一部分内容已经设置隐藏,需要回复才能查看全部内容。


2019.8.6补充提供个特征码让不想学习的,或者找不到的,直接OD搜索特征码即可
游客,当前主题有一部分内容已经设置隐藏,需要回复才能查看全部内容。


现在教下大家怎么找LOL喊话CALL。

找CALL的思路有很多种,方法都是要靠自己去分析研究,下面我演示找CALLL。

工具 CE od

ce打开编辑设置选择VEH调试器。

这里我直接提供一种超级快找CALL的方法。

减少视频大小原因我已经进入了游戏。

CE搜索文本《%d ms》找出带绿色的静态地址。右键点击选择是什么访问了这个地址。

然后游戏一直发送提示信息 直到出现目前暂不可标记地图,请稍后再试,然后停止。

由于CE我看不习惯 我就用OD了 附加进去看看代码 附加比较久,请稍等。

只要找最后出现的8A 01这个代码的地址就可以了。009F97D4

输入找到的地址 进去后 找段首,如果你们没显示哪里调用这个段首 请按右键分析代码。

这就是我公布的源码的ECX的地址  下面是喊话CALL地址。

就是这么简单。具体为什么是这里,你们可以下断点分析下。。发送喊话就会断下 并出现我们的内容就代表没有错了。

还有一种方法是搜索目前暂不可标记地图 然后对他这个文本下断点,下内存访问

然后也是一直发送,出现目前暂不可标记地图,就会断下,剩下自己慢慢跟踪下即可,也是可以找到CALL的,只是比较麻烦。

这里我就不跟踪了,自己有空慢慢分析跟踪下吧。基本我上面的方法就已经很实在了。

好了 感谢观看,请多多支持就爱江湖论坛。
LOL找喊话CALL基址教程9.205507 作者:重现江湖 帖子ID:658 喊话,基址,教程,
LOL找喊话CALL基址教程9.201198 作者:重现江湖 帖子ID:658 喊话,基址,教程,
视频回帖可见
游客,当前主题有一部分内容已经设置隐藏,需要回复才能查看全部内容。





评分

参与人数 1+1 就爱币 +1 收起 理由
Sktwy + 1 + 1 你那么流逼,你家里人知道吗?很给力!

查看全部评分


上一篇:LOL找是否进入泉水基址教程
下一篇:搭建网站基本操作-环境配置-服务器管理使用教程

发帖求助前要善用【论坛搜索】功能,那里可能会有你要找的答案,如果你在论坛求助问题,并且已经从坛友或者管理的回复中解决了问题,请在帖子回复【已解决】。

签到天数: 36

今日第157个签到

发表于 2019-6-27 18:02:43 | 显示全部楼层
感谢分享 之前请教过多个人都是直接给源码 正所谓授人以鱼不如授人以渔 支持站长这种精神
回复 支持 1 反对 0

使用道具 举报

该用户从未签到

发表于 2019-7-27 14:50:54 | 显示全部楼层
.版本 2
.支持库 iconv

.程序集 窗口程序集1
.程序集变量 pid, 整数型
.程序集变量 空白地址, 整数型

.子程序 __启动窗口_创建完毕

pid = 进程取ID (“League of Legends.exe”)
输出调试文本 (pid)
内存操作.打开进程 (pid)
空白地址 = 内存操作.创建内存 (250)
输出调试文本 (空白地址)

.子程序 _按钮1_被单击


.如果 (选择框1.选中 = 真)
    喊话CALL (0, 编辑框1.内容)
.否则
    喊话CALL (1, 编辑框1.内容)
.如果结束


.子程序 喊话CALL
.参数 是否全队, 整数型
.参数 喊话内容, 文本型
.局部变量 结果内容, 字节集

写内存字节集 (pid, 空白地址, 编码转换 (到字节集 (喊话内容), #编码_GBK, #编码_UTF_8, ))
' 输出调试文本 (“ss” + 到文本 (编码转换 (到字节集 (喊话内容), #编码_GBK, #编码_UTF_8, )))
置汇编代码 ({  })
Pushad ()
Mov_ECX_Ptr (54158308)
Push (是否全队)
Push (空白地址)
Mov_EBX (9162192)
Call_EBX ()
Popad ()
ret ()
开始Virus ()
汇编远程执行 (取汇编代码 ())
结束Virus ()
这样写软件会崩溃,喊话也没用为什么?

点评

你这样写是没写入汇编的,源码公布过,你下载论坛的源码。。  详情 回复 发表于 2019-8-6 15:40
回复 支持 反对

使用道具 举报

签到天数: 15

该用户今日未签到

发表于 2019-8-30 09:45:13 | 显示全部楼层
看看                      学习学习
回复 支持 反对

使用道具 举报

签到天数: 68

该用户今日未签到

发表于 2019-6-22 21:23:39 | 显示全部楼层
学习下 感觉很 牛笔啊
回复 支持 反对

使用道具 举报

签到天数: 94

该用户今日未签到

发表于 2019-6-22 21:48:33 | 显示全部楼层
萬分感謝LOL找喊话CALL基址教程9.202087 作者:清风阁丶Hunter 帖子ID:658 喊话,基址,教程,
回复

使用道具 举报

该用户从未签到

发表于 2019-6-22 22:41:27 | 显示全部楼层
333333333333333331
回复 支持 反对

使用道具 举报

签到天数: 46

该用户今日未签到

发表于 2019-6-23 00:25:46 | 显示全部楼层
谢谢大佬的分享 来看看
回复 支持 反对

使用道具 举报

签到天数: 33

该用户今日未签到

发表于 2019-6-23 00:30:55 | 显示全部楼层
学习下   牛批
回复 支持 反对

使用道具 举报

签到天数: 100

该用户今日未签到

发表于 2019-6-23 07:10:39 | 显示全部楼层
感谢分享!膜拜
回复 支持 反对

使用道具 举报

签到天数: 18

该用户今日未签到

发表于 2019-6-23 07:39:18 | 显示全部楼层
感谢老大教程
回复 支持 反对

使用道具 举报

签到天数: 45

该用户今日未签到

发表于 2019-6-23 10:16:35 | 显示全部楼层
来学习一下了
回复 支持 反对

使用道具 举报

签到天数: 13

该用户今日未签到

发表于 2019-6-23 22:35:26 | 显示全部楼层

学习下 感觉很 牛笔啊LOL找喊话CALL基址教程9.207408 作者:sammir 帖子ID:658 喊话,基址,教程,LOL找喊话CALL基址教程9.209512 作者:sammir 帖子ID:658 喊话,基址,教程,LOL找喊话CALL基址教程9.201086 作者:sammir 帖子ID:658 喊话,基址,教程,
回复 支持 反对

使用道具 举报

游客
回复
您需要登录后才可以回帖 登录 | ★立即注册★

免责声明
就爱江湖论坛所发布的一切软件逆向解密分析文章及视频、破解补丁、注册机和注册信息,仅限用于学习和研究目的。不得将上述内容用于商业或者非法途径!否则,一切后果请用户自负!
本站信息来自互联网,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请购买注册正版软件,获得正版优质服务!
如有侵权请邮件与我们联系处理。

E-Mail To:2710763@QQ.COM

手机版|小黑屋| 就爱江湖论坛 - Www.92Jh.Cn ( 粤ICP备19051526号 | 粤公网安备 44180202000464号 )

GMT+8, 2019-10-20 11:53

Powered by Discuz!

© 2001-2019 Comsenz Inc.

快速回复 返回顶部 返回列表